package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(\d+)|),(?:(\d+)|),(?:(\d+)|),(?:(\d+)|)`)
var str = `1,,,4`
var substitution = "\1;\4"
fmt.Println(re.ReplaceAllString(str, substitution))
}