import Foundation
let pattern = #"^(?:(\d+)|),(?:(\d+)|),(?:(\d+)|),(?:(\d+)|)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"1,,,4"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1;\4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)