use strict;
my $str = '1,,,4';
my $regex = qr/^(?:(\d+)|),(?:(\d+)|),(?:(\d+)|),(?:(\d+)|)/mp;
my $subst = '\\1;\\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";