using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(\d+)|),(?:(\d+)|),(?:(\d+)|),(?:(\d+)|)";
string substitution = @"\1;\4";
string input = @"1,,,4";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}