re = /^(?:(\d+)|),(?:(\d+)|),(?:(\d+)|),(?:(\d+)|)/m
str = '1,,,4'
subst = '\\1;\\4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result