# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\h*\R(?=[a-z])(?!or$)/ /gm;t' <<< "Books are an effective way to
communicate across time, both from the past and into the future.
Chapter 3
The Importance of Reading
or
Literature is the most agreeable way of ignoring life
"