# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\h*\R(?=[a-z])(?!or$)"
test_str = ("Books are an effective way to \n"
"communicate across time, both from the past and into the future.\n\n"
"Chapter 3 \n"
"The Importance of Reading \n"
"or\n"
"Literature is the most agreeable way of ignoring life\n")
subst = " "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.