const regex = /\h*\R(?=[a-z])(?!or$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\h*\\R(?=[a-z])(?!or$)', 'gm')
const str = `Books are an effective way to
communicate across time, both from the past and into the future.
Chapter 3
The Importance of Reading
or
Literature is the most agreeable way of ignoring life
`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);