$re = '/\h*\R(?=[a-z])(?!or$)/m';
$str = 'Books are an effective way to
communicate across time, both from the past and into the future.
Chapter 3
The Importance of Reading
or
Literature is the most agreeable way of ignoring life
';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;