re = /\h*\R(?=[a-z])(?!or$)/m
str = 'Books are an effective way to
communicate across time, both from the past and into the future.
Chapter 3
The Importance of Reading
or
Literature is the most agreeable way of ignoring life
'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result