import Foundation
let pattern = #"\h*\R(?=[a-z])(?!or$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Books are an effective way to
communicate across time, both from the past and into the future.
Chapter 3
The Importance of Reading
or
Literature is the most agreeable way of ignoring life
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)