using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\h*\R(?=[a-z])(?!or$)";
string substitution = @" ";
string input = @"Books are an effective way to
communicate across time, both from the past and into the future.
Chapter 3
The Importance of Reading
or
Literature is the most agreeable way of ignoring life
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}