#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\h*\R(?=[a-z])(?!or$)"
Local $sString = "Books are an effective way to " & @CRLF & _
"communicate across time, both from the past and into the future." & @CRLF & _
"" & @CRLF & _
"Chapter 3 " & @CRLF & _
"The Importance of Reading " & @CRLF & _
"or" & @CRLF & _
"Literature is the most agreeable way of ignoring life" & @CRLF & _
""
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)