import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\h*\\R(?=[a-z])(?!or$)";
final String string = "Books are an effective way to \n"
+ "communicate across time, both from the past and into the future.\n\n"
+ "Chapter 3 \n"
+ "The Importance of Reading \n"
+ "or\n"
+ "Literature is the most agreeable way of ignoring life\n";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}