#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[1-9]\d{0,2}(?:\.\d{3})*,\d{2}|0\d*,\d+)$"
Local $sString = "0,000001" & @CRLF & _
"0,000000001" & @CRLF & _
"1,00" & @CRLF & _
"1.000,00" & @CRLF & _
"0,1000000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")