package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[1-9]\d{0,2}(?:\.\d{3})*,\d{2}|0\d*,\d+)$`)
var str = `0,000001
0,000000001
1,00
1.000,00
0,1000000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}