using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[1-9]\d{0,2}(?:\.\d{3})*,\d{2}|0\d*,\d+)$";
string input = @"0,000001
0,000000001
1,00
1.000,00
0,1000000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}