$re = '/^(?:[1-9]\d{0,2}(?:\.\d{3})*,\d{2}|0\d*,\d+)$/m';
$str = '0,000001
0,000000001
1,00
1.000,00
0,1000000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);