import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[1-9]\\d{0,2}(?:\\.\\d{3})*,\\d{2}|0\\d*,\\d+)$";
final String string = "0,000001\n"
+ "0,000000001\n"
+ "1,00\n"
+ "1.000,00\n"
+ "0,1000000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}