const regex = /^(?:[1-9]\d{0,2}(?:\.\d{3})*,\d{2}|0\d*,\d+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[1-9]\\d{0,2}(?:\\.\\d{3})*,\\d{2}|0\\d*,\\d+)$', 'gm')
const str = `0,000001
0,000000001
1,00
1.000,00
0,1000000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}