import re
regex = re.compile(r"^(?:[1-9]\d{0,2}(?:\.\d{3})*,\d{2}|0\d*,\d+)$", flags=re.MULTILINE)
test_str = ("0,000001\n"
"0,000000001\n"
"1,00\n"
"1.000,00\n"
"0,1000000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")