package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<VAR name="faxstatus" value="(?<faxstatus>.*?)".*?`)
var str = `<?xml version="1.0" encoding="UTF-8" standalone="yes"?><ANGELXML><MESSAGE><PLAY><PROMPT type="text"/></PLAY></MESSAGE><VARIABLES><VAR name="faxstatus" value="success"/></VARIABLES></ANGELXML>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}