import re
regex = re.compile(r"<VAR name=\"faxstatus\" value=\"(?<faxstatus>.*?)\".*?", flags=re.MULTILINE)
test_str = "<?xml version=\"1.0\" encoding=\"UTF-8\" standalone=\"yes\"?><ANGELXML><MESSAGE><PLAY><PROMPT type=\"text\"/></PLAY></MESSAGE><VARIABLES><VAR name=\"faxstatus\" value=\"success\"/></VARIABLES></ANGELXML>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")