use strict;
my $str = '<?xml version="1.0" encoding="UTF-8" standalone="yes"?><ANGELXML><MESSAGE><PLAY><PROMPT type="text"/></PLAY></MESSAGE><VARIABLES><VAR name="faxstatus" value="success"/></VARIABLES></ANGELXML>';
my $regex = qr/<VAR name="faxstatus" value="(?<faxstatus>.*?)".*?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}