import Foundation
let pattern = #"<VAR name="faxstatus" value="(?<faxstatus>.*?)".*?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<?xml version="1.0" encoding="UTF-8" standalone="yes"?><ANGELXML><MESSAGE><PLAY><PROMPT type="text"/></PLAY></MESSAGE><VARIABLES><VAR name="faxstatus" value="success"/></VARIABLES></ANGELXML>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)