import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<VAR name=\"faxstatus\" value=\"(?<faxstatus>.*?)\".*?";
final String string = "<?xml version=\"1.0\" encoding=\"UTF-8\" standalone=\"yes\"?><ANGELXML><MESSAGE><PLAY><PROMPT type=\"text\"/></PLAY></MESSAGE><VARIABLES><VAR name=\"faxstatus\" value=\"success\"/></VARIABLES></ANGELXML>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}