# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a\s[^<>]*>([^<>]*)<\\/a>//gm;t' <<< "<a href=\"/?genre=Action\">Actions</a> <a href=\"/?genre=Sci-Fi\">Sci-Fi</a>"