import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a\\s[^<>]*>([^<>]*)<\\/a>";
final String string = "<a href=\"/?genre=Action\">Actions</a> <a href=\"/?genre=Sci-Fi\">Sci-Fi</a>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}