import re
regex = re.compile(r"<a\s[^<>]*>([^<>]*)<\/a>", flags=re.MULTILINE)
test_str = "<a href=\"/?genre=Action\">Actions</a> <a href=\"/?genre=Sci-Fi\">Sci-Fi</a>"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)