// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<a\s[^<>]*>([^<>]*)<\/a>").unwrap();
let string = "<a href=\"/?genre=Action\">Actions</a> <a href=\"/?genre=Sci-Fi\">Sci-Fi</a>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}