use strict;
my $str = '<a href="/?genre=Action">Actions</a> <a href="/?genre=Sci-Fi">Sci-Fi</a>';
my $regex = qr/<a\s[^<>]*>([^<>]*)<\/a>/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";