package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<a\s[^<>]*>([^<>]*)<\/a>`)
var str = `<a href="/?genre=Action">Actions</a> <a href="/?genre=Sci-Fi">Sci-Fi</a>`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}