const regex = /<a\s[^<>]*>([^<>]*)<\/a>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a\\s[^<>]*>([^<>]*)<\\\/a>', 'gm')
const str = `<a href="/?genre=Action">Actions</a> <a href="/?genre=Sci-Fi">Sci-Fi</a>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);