#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "('<dox>\n|'\s*[\S \t]*)"
Local $sString = "'test begin..." & @CRLF & _
"'<dox>" & @CRLF & _
"' <member type="Public Sub" name="Increment" return="void">" & @CRLF & _
"' <param type="Integer" name="nBase" out="true" />" & @CRLF & _
"' <param type="Integer" name="nStep" out="false" />" & @CRLF & _
"' <purpose>" & @CRLF & _
"' purpose here..." & @CRLF & _
"' </purpose>" & @CRLF & _
"' </member>" & @CRLF & _
"' <member ... />" & @CRLF & _
"'</dox>" & @CRLF & _
"'other comments here..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")