// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"('<dox>\n|'\s*[\S \t]*)").unwrap();
let string = "'test begin...
'<dox>
' <member type=\"Public Sub\" name=\"Increment\" return=\"void\">
' <param type=\"Integer\" name=\"nBase\" out=\"true\" />
' <param type=\"Integer\" name=\"nStep\" out=\"false\" />
' <purpose>
' purpose here...
' </purpose>
' </member>
' <member ... />
'</dox>
'other comments here...";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}