package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`('<dox>\n|'\s*[\S \t]*)`)
var str = `'test begin...
'<dox>
' <member type="Public Sub" name="Increment" return="void">
' <param type="Integer" name="nBase" out="true" />
' <param type="Integer" name="nStep" out="false" />
' <purpose>
' purpose here...
' </purpose>
' </member>
' <member ... />
'</dox>
'other comments here...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}