use strict;
my $str = '\'test begin...
\'<dox>
\' <member type="Public Sub" name="Increment" return="void">
\' <param type="Integer" name="nBase" out="true" />
\' <param type="Integer" name="nStep" out="false" />
\' <purpose>
\' purpose here...
\' </purpose>
\' </member>
\' <member ... />
\'</dox>
\'other comments here...';
my $regex = qr/('<dox>\n|'\s*[\S \t]*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}