$re = '/(\'<dox>\n|\'\s*[\S \t]*)/';
$str = '\'test begin...
\'<dox>
\' <member type="Public Sub" name="Increment" return="void">
\' <param type="Integer" name="nBase" out="true" />
\' <param type="Integer" name="nStep" out="false" />
\' <purpose>
\' purpose here...
\' </purpose>
\' </member>
\' <member ... />
\'</dox>
\'other comments here...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);