import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "('<dox>\\n|'\\s*[\\S \\t]*)";
final String string = "'test begin...\n"
+ "'<dox>\n"
+ "' <member type=\"Public Sub\" name=\"Increment\" return=\"void\">\n"
+ "' <param type=\"Integer\" name=\"nBase\" out=\"true\" />\n"
+ "' <param type=\"Integer\" name=\"nStep\" out=\"false\" />\n"
+ "' <purpose>\n"
+ "' purpose here...\n"
+ "' </purpose>\n"
+ "' </member>\n"
+ "' <member ... />\n"
+ "'</dox>\n"
+ "'other comments here...";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}