using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""([^""\\]*(\\(.|\n)[^""\\]*)*)""[\s]*=[\s]*""([^""\\]*(\\(.|\n)[^""\\]*)*)""[\s]*;";
string input = @"""quickAudioRecord_recordButtonPressedLabel"" = ""放开来发送"";
""quickAudioRecord_layoutViewSlideToCancel"" = ""向上滑动取消"";
""quickAudioRecord_releaseToCancel"" = ""放开取消"" ;";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}