use strict;
my $str = '"quickAudioRecord_recordButtonPressedLabel" = "放开来发送";
"quickAudioRecord_layoutViewSlideToCancel" = "向上滑动取消";
"quickAudioRecord_releaseToCancel" = "放开取消" ;';
my $regex = qr/"([^"\\]*(\\(.|\n)[^"\\]*)*)"[\s]*=[\s]*"([^"\\]*(\\(.|\n)[^"\\]*)*)"[\s]*;/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}