package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"([^"\\]*(\\(.|\n)[^"\\]*)*)"[\s]*=[\s]*"([^"\\]*(\\(.|\n)[^"\\]*)*)"[\s]*;`)
var str = `"quickAudioRecord_recordButtonPressedLabel" = "放开来发送";
"quickAudioRecord_layoutViewSlideToCancel" = "向上滑动取消";
"quickAudioRecord_releaseToCancel" = "放开取消" ;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}