import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"([^\"\\\\]*(\\\\(.|\\n)[^\"\\\\]*)*)\"[\\s]*=[\\s]*\"([^\"\\\\]*(\\\\(.|\\n)[^\"\\\\]*)*)\"[\\s]*;";
final String string = "\"quickAudioRecord_recordButtonPressedLabel\" = \"放开来发送\";\n"
+ "\"quickAudioRecord_layoutViewSlideToCancel\" = \"向上滑动取消\";\n"
+ "\"quickAudioRecord_releaseToCancel\" = \"放开取消\" ;";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}