re = /"([^"\\]*(\\(.|\n)[^"\\]*)*)"[\s]*=[\s]*"([^"\\]*(\\(.|\n)[^"\\]*)*)"[\s]*;/
str = '"quickAudioRecord_recordButtonPressedLabel" = "放开来发送";
"quickAudioRecord_layoutViewSlideToCancel" = "向上滑动取消";
"quickAudioRecord_releaseToCancel" = "放开取消" ;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end