import re
regex = re.compile(r"\"([^\"\\]*(\\(.|\n)[^\"\\]*)*)\"[\s]*=[\s]*\"([^\"\\]*(\\(.|\n)[^\"\\]*)*)\"[\s]*;")
test_str = ("\"quickAudioRecord_recordButtonPressedLabel\" = \"放开来发送\";\n"
"\"quickAudioRecord_layoutViewSlideToCancel\" = \"向上滑动取消\";\n"
"\"quickAudioRecord_releaseToCancel\" = \"放开取消\" ;")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")