#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "product_default_shipping_cost:\['(.*?)'\]"
Local $sString = "product_sale_price:['19.99'], product_default_shipping_cost:['1.99'], product_type:['Newegg']"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")