const regex = /product_default_shipping_cost:\['(.*?)'\]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('product_default_shipping_cost:\\[\'(.*?)\'\\]', '')
const str = `product_sale_price:['19.99'], product_default_shipping_cost:['1.99'], product_type:['Newegg']`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}