re = /product_default_shipping_cost:\['(.*?)'\]/
str = 'product_sale_price:[\'19.99\'], product_default_shipping_cost:[\'1.99\'], product_type:[\'Newegg\']'
# Print the match result
str.match(re) do |match|
puts match.to_s
end