$re = '/product_default_shipping_cost:\[\'(.*?)\'\]/';
$str = 'product_sale_price:[\'19.99\'], product_default_shipping_cost:[\'1.99\'], product_type:[\'Newegg\']';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);