using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"product_default_shipping_cost:\['(.*?)'\]";
string input = @"product_sale_price:['19.99'], product_default_shipping_cost:['1.99'], product_type:['Newegg']";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}